Overlord: Fellowship of Evil PC Game System Requirements

Overlord Fellowship of Evil System Requirements

Overlord: Fellowship of Evil is a spin-off from the main Overlord series, with the storyline taking place after the events of Overlord II, after the Fourth Overlord has perished. Rather than focusing on a new Overlord, the game is centered around Co-Op gameplay featuring four new “candidates” for the Overlord throne; the Netherghuls!

With the last true Overlord deceased, gamers take up the role of one of four Netherghūls. These brand new, suitably nefarious additions to the series are undead servants of the dark arts, determined to bring evil back to a world overrun by the forces of good.

But where’s the fun in smiting fools alone? Join the Fellowship, grab three of your most devious friends – locally or online – and gleefully unleash a wave of delightful destruction across the land. For the Master!

Overlord: Fellowship of Evil

Developer: Codemasters
Release Date: August 25, 2015
Genre: Action, Adventure

Overlord: Fellowship of Evil Minimum System Requirements

Operating System: Windows Vista, Windows 7 or Windows 8
CPU:Intel Core 2 Duo E4600 or AMD Athlon x2 5400+
Graphics (GPU):AMD HD4870 or Nvidia GTX280
HDD:4 GB available space
Network:Broadband Internet connection
Sound Card:DirectX Compatible soundcard


Overlord: Fellowship of Evil Recommended System Requirements

Operating System:Windows Vista, Windows 7 or Windows 8
CPU:AMD FX Series or Intel Core i5 Series
Graphics (GPU):AMD R9 270 or Nvidia GTX660
HDD:4 GB available space
Sound Card:Direct X compatible soundcard

Speak Your Mind